System Requirements
Athena, our LMS, supports the most recent versions of the following browsers:

Chrome
Firefox
Safari (not supported on Windows)
We also support Internet Explorer 11 or higher.

For Windows XP users, we only support Service Pack 3.

No matter what browser you use, you should enable JavaScript.

If you're using a mobile device, we support the following:

For iPad - iOS 8.0+

Note: Other browsers might work with our LMS. However, we can't guarantee that all features will work as expected.

To view PDF documents, you must have Adobe Reader or another PDF viewer installed.